This project is read-only.

problem with .ExecuteWithReport(MethodBase.GetCurrentMethod());

Aug 2, 2012 at 6:23 PM

I have encountered a problem with ExecuteWithReport()

I have a 64 bit test,  I have tried both MS Test and NUnit running 64 bit application.

Test runs selenium and performs a simple login to a web site.

When I run the test using .Execute() the test performs successfully.

When I attempt to run with ExecuteWithReport() I get the following error:

Test method StoryQTestClass.UserLogin threw exception: System.ArgumentNullException: Value cannot be null.Parameter name: value

System.Xml.Linq.XAttribute.ctor(XName name,Object value)StoryQ.Execution.Rending.XmlCategoriser.GetOrCreateElementForMethodInfo(MethodBase categoriser)StoryQ.Execution.Rending.XmlCategoriser.GetRenderer(MethodBase categoriser)StoryQ.Infrastructure.FrameBase.ExecuteWithReport(MethodBase currentMethod)

Before I tear into debugging the StoryQ.dll I was wondering if anyone has encountered this ans has a fix or work around.








Aug 2, 2012 at 8:07 PM

I might know this one: Does your test class have a namespace?

Aug 2, 2012 at 8:24 PM

I don't know this one, however, I have had problems with MSTest on 64 bit but you have tried NUnit ruling out that problem. Go Rob!

Aug 2, 2012 at 10:09 PM
Edited Aug 2, 2012 at 10:10 PM

Hello Guys,


Thanks for the feedback.

I found the problem.  If I compile everything with 64 bit, Visual Studio test project, StoryQ.Dll project and my Selenium Project The ExecuteWithReport() fails with the above errors.  I also cannot debug step into the StoryQDll project, even when I add the project to my test solution.

If I recompile everything back to 32 bit the test project runs just fine, generating the .xml results files and I can debug the StoryQ.dll project from my test project.